Help..out of theroy's

Discussion in 'All Topics, Chips, and Tech for Buicks' started by turbocamino, Sep 13, 2019.

  1. turbocamino

    turbocamino Well-Known Member

    at a loss as to why my car now shows ways too rich on my NGK/Powerdex. I run your 5.7 Alky chip made for 26 Lbs with a JB 6265..Idle was just as you said it would at 13.2 warm and WOT at 11.2, like you said it would..car went 125..high tens. Last winter i upgraded to -8 feed and -6 return and a stronger,DW350IL pump,,old pump was fine but getting old and i upgraded. The issue> I just bought a Bison 6766JB turbo and bolted it on with no other changes but fuel line and pump ,adjusted f/p back down to 43. First blast showed 26 Lbs ..and did feel lazy, .. a glance at WB showed 9.4 ..plugs look rich too. How can this be with a 90Lb/mn verses 70Lb/mn turbo..why wasnt it very lean?. I cant verify WOT f/p as my gauge is junk and never reads even close othr than idle. I also did bolt on a spare F/P reg i have and it showed same W/B # at WOT 9.4. I dont feel comfortable just pulling fuel without an logical reason for this?
     
  2. turbocamino

    turbocamino Well-Known Member

    ...should mention it does feel like the converter is coupling welll at shifts,, just a few hundred drop like before... easiest thing was to think there is no load on motor and running thru the converter... a PTC 9.5n/l spect for the 6265
     
  3. turbocamino

    turbocamino Well-Known Member

    ... next test was to see if i could 'use up' some of the excess fuel...i turned boost up to 28Lbs...and saw no real change in a/f? i did see a 9.6 in second but still 9.4 in 3rd. Map sensor is a guess?
     
  4. turbocamino

    turbocamino Well-Known Member

    ..and this rich condition is during the whole rpm range at WOT 2nd and 3rd
     
  5. EricM

    EricM Administrator Staff Member

    Could be the wideband is wrong, alcohol spraying wrong amount, make sure the chip WOT fuel parameter isn't maxed (should be 128 by default).
     
  6. turbocamino

    turbocamino Well-Known Member

    thanks i will look into those suggestions...chip settings triple checked...Julio redid alky pump and is on 6.5. have new NTK o/2.. Warm idle is mid 13s and cruise 16s.
     

Share This Page